Android studioでエミュレーターが起動しない

LINEで送る
Pocket

エミュレータ―が動かなかったが、簡単に動いた。

 

以下行ったことを書いておく。

 

今回出たエラーメッセージ

Could not initialize OpenglES emulation, use ‘-gpu off’ to disable it.

Warning: requested ram_size 1536M too big, reduced to 1024M

 

この2つ。

上は、「グラフィックドライバーが古いぞ更新しろ!」

下は、「ramサイズでけーから減らせ!」と言ってる。

 

順番に書いてく。

 

 

グラフィックドライバーの更新

 

まず上のエラー。

 

「コントロールパネル→ハードウェアとサウンド→デバイスとプリンターのデバイスマネージャー→ディスクプレイ アダプター」

 

 

後は右クリックで「ドライバーソフトウェアの更新」でおっけー。

 

HAXMの再インストール

 

初期設定を1024とかにしてるとダメっぽい。

再インストールする必要があるが、ここでちょっとハマった。

 

はじめ、「Tools→Android→SDKマネージャー」からチェック外す→もっかいチェックしてインストールってやってたんだけどだめらしい。

 

で、インテルのHP見ながら再インストールしたら動いた。

 

(参考にしたサイト:インテルHP

https://software.intel.com/en-us/android/articles/installation-instructions-for-intel-hardware-accelerated-execution-manager-windows

https://software.intel.com/en-us/android

 

から、右上にHAXMで検索してインストーラーのダウンロード。

インストーラー起動して、古いのあるけど続ける?って聞かれるからOK。

あとは、デフォルトの2ギガで。

 

おしまい。

これでエミュレーター起動するはず。

 

余談

・お絵かき楽しい(^▽^)。

・よくわからんエラーが発生したら、それコピってグーグル先生に聞けば解決できる。

この際、「エミュレーター 起動しない」とかで検索しないほうがいい。ハマる。

・というわけで、英語だいじ。

・できないとウザいが、ブログのネタになるのでまあいい。

 

Androidアプリ作りたくて始めたが、環境設定がいつもながらにだるすぎる。

あとJavaよくわかんない^^

べんきょーべんきょー。

LINEで送る
Pocket

Leave a Reply

Your email address will not be published.